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About Teleprinter 
 
Teleprinter, from morelearning, is an educational software package which can be used with students to 
enable them to work as a team to analyse information, make decisions and role play all whilst having fun. 
Teleprinter works by providing information to students at pre-defined intervals.  Teleprinter provides the 
students with data about a situation which the students use to plan an activity and in doing so develop 
their teamworking, analysis, decision making and leadership skills.  With the ever-increasing focus on ICT 
in the National Curriculum, Teleprinter offers the opportunity for both students and teachers to use ICT in 
a constructive manner.  Teleprinter may be used as a teaching aid for diverse subjects. 
   
To run Teleprinter you need the following: 
• A PC with Microsoft Windows XP (Teleprinter should work with Windows 95 and up, but this has not 

been tested). 
• The Teleprinter application package 
• A Datafile containing information items. 
• A printer 
 
Pre-Installation Checks 
 
Before installing Teleprinter please check the following: 
1. Your PC is running Microsoft Windows XP (Teleprinter should run on Windows 95 or higher, but this 

hasn't been tested). 
2. The screen resolution is set to at least 800x600 
3. No other programs are running. 
 
Installing Teleprinter 
 
1. After downloading Teleprinter from the morelearning website double click on the downloaded file, 

Install_Teleprinter.exe, to begin the installation.  
2. The following window will be displayed: 
 

 



3. Click on the Setup button to begin Teleprinter Installation. 
4. System files will be copied to your PC during which time a message similar to the following will 

appear (the actual message will depend on your system’s setup and hardware). Once the required 
system files have been copied your PC will be checked to see if a restart is required. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

. 
5. If the following message appears go to step 6, otherwise go to step 10. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
6. Click OK.  These files must be updated or Teleprinter will not run correctly. 
7. Once the files are updated the following message will appear: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
8. Click Yes to restart windows. 
9. Once windows has restarted run setup again by repeating the previous steps, and then move on to 

step 10. 



10. The morelearning End User Licence Agreement (EULA) will be displayed. 
11. Please read the EULA carefully.  If you accept the terms and conditions of the EULA and agree to 

abide by them then click on the I Agree button, otherwise click on the I Do Not Agree button to 
cancel the installation of Teleprinter. 

12. If you agreed to the terms and conditions of the EULA a new screen is shown reminding you to 
close any other applications. Click on OK to continue. 

13. The begin installation screen will now be displayed as show below. It is recommended you don’t 
change the installation directory.  Click on the Install button to begin the installation. 

 
 

 
 
 
14. The Choose Program Group screen will now be displayed as shown below.  It is recommended that 

you don’t change the program group.  Click on the Continue button to install Teleprinter. 
 

 
 
 
15. When Teleprinter setup is complete the following window will be displayed: 



 
 
 
16. To run Teleprinter select Teleprinter from the Start menu (it will be under Programs). 
 
 

Basic Teleprinter Operation 
 
Teleprinter is easy to use by following a series of simple steps.  You do not have to follow all of the steps 
every time you run Teleprinter but it's advisable to do so initially until you are happy with using 
Teleprinter and have a good idea of the correct settings to use for your system. 
 
Selecting a Printer 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Printing a Test Line 
 
The settings you use with Teleprinter will be determined by the capabilities of your printer.   The best 
Font, Font Size, Margin and Line Length attributes for your requirements and system can be determined 
by using the Print Test item from the Options menu.  Initially the attributes are set to default values 
which are likely to work on many different PCs.  To see how these look on your system ensure your 
printer is connected and turned on and then select the Print Test item from the Options menu or click on 
the Print Test icon on the toolbar. This will print a test line which will enable you to set print attributes.  
If you have kept the default values for margin, font and font size, then the test line will look something 
like the example overleaf and can be used to determine the maximum line length.  Be sure to choose a 
value that will fit onto one line.  In the example below the test line has a margin of 5 spaces then printing 
begins with the letter a.  The letter j is 10 characters along, as indicated by the number 10 pointing at it 
(j<-10), the letter o is 20 characters along and so on up to the letter n at 70 characters. 
 
Margin =  5 spaces, Font = Courier New, Size =  10 
     abcdefghij<-10 klmno<-20 pqrst<-30 uvwxy<-40 zabcd<-50 efghi<-60 jklmn<-70 op 
 
 
Generally the maximum line length should be no more than the largest numerical value showing on the 
test line, in this case 70.  Note: If you set a maximum line length greater than that allowable for the 
settings of margin, font and font size, then your text may be truncated. 

The first thing to do is to select which printer you want to send the output 
from Teleprinter to. If you are happy to send the output to the default printer 
for this PC move on to Printing a Test Line.  If you want to change the output 
printer or just check which printer is currently set as the default then from the 
Options menu choose the Printer item, or click on the Select Printer icon on the 
toolbar.  The printer selection dialogue will be displayed and initially this will 
show the current default printer for the machine you are using.  If you are 
happy with this simply click on Cancel, otherwise select the printer you want to 
use for output and set any of the properties you require and click on OK.  The 
printer attributes for this Teleprinter session are now set and you can move on 
to the next step, Printing a Test Line 
 



 
You can change the values for the margin, font and font size but be aware that these will change the 
value of maximum line length e.g. a bigger font size will cause the maximum line length to decrease.  
After making any changes print a test line and set the maximum line length attribute accordingly.  Once 
you are happy with the settings move on to the next step, Opening a Datafile. 
 
 
Opening a Datafile 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Starting a Datafile 
 
Before starting the Datafile you need to let Teleprinter know the number of groups of students you have. 
This determines how many times each item from the Datafile is printed.  Set this to whatever value you 
require (for now between 1 and 3 is probably sufficient). From the File menu select the Start item or click 
on the Start icon on the toolbar and the Datafile run will begin.  The start and end times are displayed 
along with the time until the next item will be printed which should be counting down toward 0:00.  
Check the printer, items should be printing.   
 
 
Pausing a Datafile 
 
You may pause a Datafile at any time by selecting Pause from the File Menu or clicking on the Pause icon 
on the toolbar.  The countdown until the next item will stop and the finish time will start to increase.  To 
start the Datafile again go to the File menu and select select Pause or click on the Pause icon on the 
toolbar.  The countdown until the next item will begin again and the finish time will now be fixed.  At any 
time you may not want to wait for the next item so you can force the next item to print immediately. 
 
Forcing the Next Item 
 
During a Datafile run you may want to print the next item without waiting the specified time.  You can do 
this by selecting Next Item Now from the File menu or click on the Next Item Now icon on the toolbar.  It 
is also possible to Stop a Datafile run. 
 
Stopping a Datafile 
 
During a Datafile run you may want to stop the Datafile.  You can do this by selecting Stop from the File 
menu or click on the Stop icon on the toolbar.  The Datafile stops immediately and cannot be 
automatically restarted.  If you want to restart the Datafile again then select Pause rather than Stop. 
 

You need to tell the Teleprinter application which Datafile you want to use.  
Note: With the unregistered version of Teleprinter you can only use the 
demonstration Datafile supplied, demo.txt.  Select the Open item from the 
File menu or click on the Open icon on the toolbar and the file selection 
dialogue will be displayed.  Initially this is set to the Teleprinter directory and 
you will see the demo.txt Datatfile.  Select demo.txt by clicking once on it and 
then click on the Open button.  The file selection dialogue will close and the 
selected Datafile will be displayed on the caption bar. The running time is also 
displayed, the demo.txt Datafile taking 5.5 minutes to run.  Now you are 
ready to start the Datafile. 
 



Further Teleprinter Operations 
 
Adding an Automatic Time Header 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Adding an Automatic Item Header 
 
Teleprinter can, if required,  automatically add a text header to each item that is printed out.  This can be 
done by selecting Item Header from the Options menu, or by clicking on the Item Header icon on the 
toolbar.  When Teleprinter is started Item Header is set to on by default.  When Item Header is on the 
associated menu and toolbar icons appear to be pressed in and the text in the Item Header box will be 
included with every item printed.  Selecting Item Header will toggle between Item Header being on and 
off.  The Time Header option works in a similar manner.  The Preview option can be used to see the 
effect of this setting.  Note: If a Datafile contains Time and Item header information this will override the 
current settings when the Datafile is opened.  See Creating Your Own Datafiles for further information on 
this. 
 
Reminders 
 
Teleprinter Datafiles can have reminder controls placed in them which cause a window to be displayed at 
a certain point during a Datafile run to remind you to do something e.g. a press conference (see Creating 
your own Datafiles for further information).  The display of the reminder  window can be controlled by 
selecting the Reminder item from the Options menu or clicking on the Reminder icon on the toolbar.  
When Teleprinter is started Reminder is set to on by default.  When Reminder is on the menu and toolbar 
icons appear to be pressed in and any reminders in the Datafile will be displayed.  Selecting Reminder will 
toggle between Reminder being on and off.  The Preview option can be used to see the effect of this 
setting i.e. any Reminders in the Datafile will not be displayed unless Reminders are turned on. 
 
Enumeration 
 
Teleprinter includes a facility to include the number of each item on the Header line as it is printed out.  
This is useful if you are running a lesson alone by informing you what stage the Datafile run is at without 
returning to the computer.  Enumeration is turned on by selecting the Enumerate item from the Options 
menu or by clicking on the Enumerate icon on  the toolbar.  When Teleprinter is started Enumerate is set 
to off by default.  When Enumerate is on the menu and toolbar icons appear to be pressed in and the 
number of the current Datafile item is printed at the end of the Heading line.  Selecting Enumerate  will 
toggle between Enumerate being on and off.  The Preview option can be used to see the effect of this 
setting.  Note: Since the enumeration is added at the end of the Header line, Enumeration can only be 

Teleprinter can, if required,  automatically add the 
current time to each item that is printed out.  This can 
be done by selecting Time Header from the Options 
menu, or by clicking on the Time Header icon on the 
toolbar.  When Teleprinter is started Time Header is 
set to on by default  When Time Header is on the 
associated menu and toolbar icons  appear to be 
pressed in and the current time will be included with 
every item that is printed.  Selecting Time Header will 
toggle between Time Header being on and off. The 
Item Header option works in a similar manner. The 
Preview option can be used to see the effect of this 
xxxx setting.   Note: If a Datafile contains Time and Item header information this will override the current 

settings when the Datafile is opened.  See Creating Your Own Datafiles for further information on this. 
 



used if either Time Header or Item Header (or both) are on. 
 
Hide Next Item In 
 
Teleprinter displays the time to go until the next data item is printed.  Teleprinter includes a facility to 
hide this value.  This may be useful if the computer on which Teleprinter is running is easily visible - 
students may then be aware of when the next item is being printed, which can be undesirable.  To hide 
the time until the next item is printed select Hide Next Item In from the Options menu.  This can be done 
before starting a Datafile, or during a Datafile run.  Once the Datafile is running Hide Next Item In is 
greyed out and cannot be selected again.  The time remaining until the next item is printed will remain 
hidden until the Datafile is either completed or stopped.  
 
Include Group Numbers 
 
Teleprinter has the option of including group numbers on each data item that is printed out.  To include 
group numbers select Include Group Numbers from the Options menu.  An extra line is automatically 
added before each data item indicating the group number. 
 
 
Using Start At and Stop After with Place Markers 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Datafile Preview 
 
 
 
 
 
 
 
 
 
 
 
 
 
Preview item of the Options menu, or for an Immediate Preview, click on the Immediate Preview icon on 
the toolbar, and the preview window will then be displayed.  Use the scroll bar to check all of the output.  

Teleprinter gives you the option of starting and stopping the Datafile at 
place markers within the Datafile.  This can be useful if the same Datafile 
is going to be used over several lessons.  Place markers are put in the 
Datafile before data items.  For example, in the demo.txt Datafile there 
are five items, each of which has a place marker.  In demo.txt these are 
labeled Item 1, Item 2, Item 3, Item 4 and Item 5.  To start the demo.txt 
Datafile at any place marker first open the demo.txt Datafile and then 
select the Start At drop down box.  From here you can select a place 
marker to Start At.  If Start At is left blank the Datafile items will be 
printed out from the start of the Datafile.  Similarly you can select the 
data item to Stop After.  Note: Stop After means print the item and then 
dd stop so the item you choose to Stop After will be printed!   If Stop After is left blank the Datafile items will 

only stop printing when the end of the Datafile is reached or the Datafile is manually stopped.  The 
Preview option can be used to check what will be printed. 
 

Teleprinter provides two preview modes so that the items to 
be printed can be checked, Immediate Preview and 
Realtime Preview.  Immediate Preview displays the 
complete output of a Datafile run in a window for inspection 
instantly, the timing information in the Datafile is ignored. 
Realtime Preview displays the complete output of a Datafile 
run in a window but the timing information in the Datafile is 
used.  Note that for a Realtime Preview the same options 
are are available as for a Datafile run using the printer e.g. 
Pause, Next Item Now etc. To preview demo.txt first open 
the Datafile then select either immediate or realtime from      
. 



The preview window is set to represent an A4 sheet with the same character indicator at the top as is 
used for the Printing a Test Line option.  You can use this to experiment with setting different values for 
line length, margin, font and font size, groups, Start At, Stop After etc. before actually sending the 
Datafile to the printer.  However, you should always print at least one item on the printer to test your 
chosen settings since printer setup and drivers can and do vary.  Note: You must close the Preview 
window before starting a printed Datafile run. 
 
If pictures are included in the Datafile, such as the picture of the Queen in demo.txt,  then these are also 
displayed in the preview window.  However, pictures are very resource intensive and can use a great deal 
of your PCs memory and disk space.  For example, if you set groups to the maximum value of 32 and 
preview the demo.txt Datafile, approximately 10Mb of memory will be used when displaying the preview 
window.  Larger pictures or the inclusion of more pictures will cause memory usage to increase and may 
cause "Out Of Memory" errors to be displayed on your system.  If this occurs, or previewing a Datafile 
with pictures takes a long time, you can select the Include Pictures item from the Options menu.  By 
default this is ticked and pictures are included in both Immediate and Realtime previews. If you select it 
the tick will disappear and a small, low memory default image will be displayed in the preview window in 
place of the actual image to help conserve system resources.  Note: This only affects previewing 
Datafiles;  pictures are always sent to the printer after Starting a Datafile. 
 
 
Creating Your Own Datafiles 
 
With the registered version of Teleprinter you are free to create and use Datafiles of your own.  The 
Datafile included (demo.txt) can be used as a template for your own Datafiles.  Datafiles are easy to 
create and the following notes will help you to create Datafiles which run successfully. 
 
Datafiles consist of comments, the information to be printed and controls to tell the Teleprinter 
Application what to do. 
 
Comments 
Lines beginning with a hash (#) symbol are comments and are ignored. Note: The hash must be the first 
character in the line for a comment. 
 
# If these lines were in Datafile they would be 
# ignored because the lines begin with a hash 
 
Controls 
Controls are always enclosed in chevrons (the < and > symbols), occupy a line of their own and consist 
of lower case characters only.  Therefore <wait 1> in a Datafile is a control that tells Teleprinter to wait 
for 1 minute before continuing.  The Teleprinter controls are described below: 
 
<wait x> 
x = number of minutes to wait 
The <wait x> control contains timing information  e.g.  <wait 1> means wait for 1 minute, <wait 1.5> 
means wait 1.5 minutes etc.  Wait times must be greater than 0 minutes and less than 60 minutes. 
 
<picture picname.jpg> 
The picture control is used to tell Teleprinter to display a picture.  Picture files can be in jpg, bmp, wmf or 
gif format.  Teleprinter expects pictures to be found in the Teleprinter Images directory.  The location of 
this on your PC will depend on the options chosen at installation time but if the default options were used 
this will be C:\Program Files\Teleprinter\Images.  The picture control must come after the text of a data 
item and there can only be one picture control per data item. 
 



<timeheader on>  
This control turns on a time header for each printed item. 
 
<timeheader off>  
This control turns off a time header for each printed item 
 
<itemheader News Flash> 
This control turns on an item header for each printed item.  In this case the header would be set to 
"News Flash" but you can set it to any text you require. 
 
<itemheader> 
This control turns off the item header for each printed item 
Note: The timeheader and itemheader controls operate when a Datafile is opened, not when it is running.  
For example, the default item header is set to “- AGENCY NEWS FLASH” when Teleprinter is started.  If a 
Datafile contained the control <itemheader>, and was opened immediately after starting Teleprinter then 
item headings would be turned off.  If item headings are manually turned back on by selecting Item 
Header from the Options menu or clicking on the Item Header icon on the toolbar before running the 
Datafile, they would be included in the output. 
 
<marker Item 1> 
This control is a place marker.  In this case the place marker would be "Item 1" but you can set it to any 
text you require.  Markers are used to start and end the Datafile at that point.  You can Start At or Stop 
After a place marker when running the Teleprinter application. 
 
<end>  
Indicates the end of the Datafile and is mandatory in every Datafile or an error will occur.  This must be 
the last item in a Datafile and nothing must follow it. 
 
<reminder Press Conference 1 Due> 
The reminder control can be used to display a window to remind you to do something.  In this case the 
window would contain the message "Press Conference 1 Due" but this can be set to show any text you 
require. 
 
<newpage> 
When there is more than one group, individual data items for each group are printed on the same sheet 
of paper (unless the data item includes a picture, in which case that item is printed on a new sheet for 
each group).  The newpage control can be used to force an individual data item to be printed on a new 
page for each group.  Newpage must come after the text of a data item. 
 
Layout 
Datafiles should be constructed in a particular way to prevent errors occurring.  The first items in a 
Datafile should be the timeheader and itemheader controls.  These are optional and do not have to be 
included. The last item in a Datafile must be the end control which is mandatory.  In between are the 
data items which should be in the following order:  marker (optional), reminder (optional), data, picture 
(optional) and wait. 
 
Teleprinter Datafiles are plain text files.  To create your Datafile there are several options.  You can use 
the inbuilt Teleprinter Datafile Editor or a  simple text editor such as Microsoft Notepad.  You may use a 
word processing package such as Microsoft Word but you must save your Datafile in text format i.e. 
yourfile.txt.  Make sure you keep the length of each line reasonable i.e. to around the maximum number 
of characters that can fit across a sheet of A4 given the font and margin settings you want to use - 128 
characters is a good rule of thumb.  Line lengths in Zoltan Systems Datafiles rarely exceed 100 
characters.  This is particularly true if you use a word processing package rather than the Teleprinter 



Datafile Editor in which case you should break up long paragraphs by inserting carriage returns at the 
end of every line. 
 
Teleprinter does not add any blank lines to the Datafile, you must add these as well as well as the actual 
text.  Don't worry if the length of any lines in your Datafile is longer than the Max Line Length setting,  
Teleprinter will automatically format them.  However, lines that are shorter than this will not be joined. 
 
You can use the Preview option to check your Datafile as you edit it, but remember to save the Datafile 
first and reopen it from the File menu by selecting the Open option, or by clicking on the Open icon on 
the toolbar, or the changes will not get picked up. 
 
 


